Asset objects might be displayed as "Object data missing" in JXL sheets because Atlassian Jira APIs intermittently stop responding with the requested data.
We have worked through this problem with Atlassian. They have identified the cause on their side. Atlassian-internal secondary API requests are hitting recently newly established rate limits when large amounts of asset objects data are requested. The resulting request failures are not transparent to external apps such as JXL. Data is silently omitted, which is why we cannot improve this experience e.g. by serving more graceful and descriptive error messages at this point.
Atlassian has categorised this fix as a feature request and created https://jira.atlassian.com/browse/JSDCLOUD-18576 to track it. We can only highly recommend everyone affected to engage there by upvoting, commenting, and watching the work item. Additionally, if you have a Customer Success Manager, we suggest bringing it up with them as well. The ideal outcome would be if Atlassian decided to continue to allow larger amounts of your data to be retrieved.
Posted Mar 04, 2026 - 23:10 UTC
Update
Asset objects might be displayed as "Object data missing" in JXL sheets because Atlassian Jira APIs have intermittently stopped responding with the requested data. We have filed incident ECOHELP-113734 with Atlassian and are actively working with them on the problem. Atlassian has narrowed it down to an internal API's request limiting behaviour, but have yet "determine what options we have to reduce the impact".
Posted Feb 26, 2026 - 21:24 UTC
Update
Asset objects might be displayed as "Object data missing" in JXL sheets because Atlassian Jira APIs have intermittently stopped responding with the requested data. Potential causes being investigated include changes in assets permission interpretation, data volume, and API request limits. We have filed incident ECOHELP-113734 with Atlassian and are still awaiting their help and escalation on the case.
Posted Feb 23, 2026 - 21:48 UTC
Identified
Some asset objects might be displayed as "Object data missing". This is caused by Atlassian Jira APIs, which have intermittently stopped responding with the requested data. We have filed incident ECOHELP-113734 with Atlassian and are awaiting their first response on the case.
Posted Feb 20, 2026 - 10:35 UTC
This incident affected: JXL for Jira Cloud (Atlassian Jira APIs).