Updating story points fails for some customers
Incident Report for JXL
Resolved
This incident has been resolved.
Posted Jul 13, 2022 - 13:03 UTC
Identified
The issue has been identified and a fix is in deployment
Posted Jul 13, 2022 - 12:53 UTC
This incident affected: JXL for Jira Cloud (JXL application).