Some users experience an error when loading sheets

Incident Report for JXL

Resolved

This incident has been resolved.
Posted Mar 13, 2025 - 10:45 UTC

Update

We are looking into this with highest priority, and it seems like we might be affected by an underlying incident in a Jira API. We have just deployed a workaround that uses a different search API, which we believe might not be affected. We'll publish updates here promptly.

Important: To get the latest version of JXL, please reload any browser windows with sheets you might have opened.
Posted Mar 13, 2025 - 08:06 UTC

Investigating

We are currently investigating this issue.
Posted Mar 13, 2025 - 07:31 UTC
This incident affected: JXL for Jira Cloud (JXL application).